Q. Minimum Browser Requirements for EBSCO Interfaces

Answer

 

General Requirements

The Minimum Browser Requirements for EBSCO interfaces are as follows:

Firefox

Latest version plus one previous version

Safari

Latest version plus one previous version

Google Chrome

Latest version plus one previous version

Microsoft Edge

Latest Edge release plus one previous major version

Internet Explorer

10.0 or later

Other

JavaScript, Cookies Enabled, DOM Storage

 

EBSCO eBooks Requirements

The minimum Browser and Operating System requirements for reading EBSCO eBooks online are as follows:

Firefox

Latest version plus one previous version

Safari

11.0 or later

Google Chrome

Latest version plus one previous version

Internet Explorer

11.0 or later

iOS

11.0 or later

Other

JavaScript, Cookies Enabled, DOM Storage

 

EPUB Format EBSCO eBooks

EPUB titles are not viewable on versions of Internet Explorer older than IE 9. This is primarily because the EPUB format is based on XHTML technology, and versions older than IE 9 do not support XHTML. Currently, only a small number of our customers still run IE browsers older than IE 9.

If you attempt to view an EPUB format eBook, we will display a list of recommended browsers so that you can upgrade your browser and view the book. 

If you use IE and are running  an older version, you can download the latest version on Microsoft's website:

http://windows.microsoft.com/en-US/internet-explorer/download-ie

How do I update my browser?

  • Last Updated Jun 07, 2021
  • Views 0
  • Answered By Wei Ma

FAQ Actions

Was this helpful? 0   0